How to block a user after multiple invalid login attempts in EventLog Analyzer automatically

How to block a user after multiple invalid login attempts in EventLog Analyzer automatically

Objective

Prevent unauthorized access attempts in EventLog Analyzer by automatically blocking users who enter the wrong login password repeatedly within a defined timeframe.
Prerequisite
  • Administrative privileges in EventLog Analyzer.

Steps to follow

Step 1: Log in to EventLog Analyzer as an administrator.
Step 2: Go to the Settings tab, and click Admin Settings > Logon Settings > General.
Step 3: Below Block User Settings, check the Block user after invalid logon attempts box.


Step 4: In the Invalid attempts limit field, enter the maximum number of failed login attempts allowed.
Example: Enter 5 to block a user after five failed logins.
Step 5: In the within [x] mins field, specify the time period in minutes to track these attempts.
Example: Enter 30 to count failed attempts within 30 minutes.
Step 6: In the Block user for [x] mins field, enter the number of minutes the user should remain blocked.
Example: Enter 15 to block the user for 15 minutes. 

Step 7: Click Save Settings to apply the changes.

Tips

  • Avoid setting the invalid attempts limit too low (e.g., 1 or 2), as this may block users when they make typos or other common mistakes.
  • Make sure to strike the right balance between the time window to track failed logon attempts and the amount of time users are blocked after that many failed attempts to ensure tight security without negatively impacting user convenience. 
  • Consider combining this feature with CAPTCHA to enhance login protection.

Related articles and topics