Issue description
This issue occurs when EventLog Analyzer is unable to send notification emails or one-time password (OTP) emails. This may happen due to several reasons, such as incorrect email server configurations, network issues, or authentication errors. As a result, customers may experience delays or failures in receiving critical notifications or OTPs, impacting their ability to use certain features of the application.
Prerequisites
Proper network connectivity between Eventlog Analyzer and the email service provider.
Port level connectivity to the mail server is necessary in case of SMTP Service Configuration. In case of SMTP-based authentication, it is required for the user account to have Send As permission for the email address specified in the From section.
In case of Microsoft API-based configuration or SMTP-OAuth configuration, make sure to enter the Client Secret Value properly.
Make sure to use a valid email user account that is not configured with MFA in M365.
Possible causes
For EventLog Analyzer to send emails successfully, the configured SMTP Server or mail service provider APIs must be reachable from the system where EventLog Analyzer is installed. Additionally, the credentials provided must have the necessary permissions to authenticate and establish a successful connection.
Possible reasons why Eventlog Analyzer could not send out test emails are as follows.
SMTP service related causes:
Eventlog Analyzer server is unable to reach the SMTP Server.
The SMTP Server details could be incorrect.
The SMTP Server may not support basic authentication.
The user account provided for the Authentication purpose may not have send as permission for the User Account specified in the From address.
Incorrect security protocol chosen (TLS/SSL/None)
SmtpClientAuthentication is disabled for the tenant (for Microsoft email service)
Application-specific password required Error because the Gmail account being enabled with two-step verification for Authentication.
SMTP Service with OAuth related causes:
Invalid client secret value supplied
Redirect URI mismatch
Client secret value expired
PKIX path building failed due to certificate missing in Product CACERT file.
API email service related issues:
Resolution steps
Follow the steps below to identify and resolve exceptions.
Step 1: Log in to EventLog Analyzer as built in Admin user.
Step 2: Navigate to Settings-> System Settings -> Notification settings -> Check the Mail server configuration details ( with correct mail server configuration/ username and password) .
Step 3: Try sending a test email.
Step 4: If the test email fails, please proceed to the following trouble shooting steps
1. SMTP Server connectivity and basic authentication related issues:
- Verify the connectivity between Eventlog Analyzer server and the SMTP Server.
- To check the same, open Powershell within the Eventlog Analyzer server and execute the test-netconnection command as follows.
tnc <SMTPServerIP/Hostname> -p <SMTPServicePortNumber>
- For example
tnc 10.10.10.10 -p 25
If the connectivity test fails, we request you to fix the connection and try again.
If the connectivity test succeeds, then please proceed with executing the SMTP Powershell command given below to simulate a sample email send activity.
Note: Based on the results displayed in the Powershell, appropriate resolutions can be suggested.
Steps:
Login to the server where Eventlog Analyzer is installed on
Open Powershell as an administrator
Enter the commands below to verify if SMTP credentials work natively
Depending on the Security Protocol that the client's SMTP Server accepts, you can choose either one of the three powershell commands
➤
When "Use Secure Connection"=NONE:-
Example :-
➤
When "Use Secure Connection"=TLS,
[System.Net.ServicePointManager]::SecurityProtocol = 'Tls,TLS11,TLS12'
Send-MailMessage -To "<to-mail@server.com>" -From "<from-mail@server.com>" -Subject "<subject>" -SmtpServer "<smtpserver>" -port <port> -Credential "<username>" -UseSsl
➤
When "Use Secure Connection"=SSL,
[System.Net.ServicePointManager]::SecurityProtocol = 'Ssl3'
Send-MailMessage -To "<to-mail@server.com>" -From "<from-mail@server.com>" -Subject "<subject>" -SmtpServer "<smtpserver>" -port <port> -Credential "<username>" -UseSsl
- Replace the fields surrounded by angular brackets. For example :-
- If you receive the following errors when executing the above scripts via Poweshell, please find the next course of action
In case of timeout error, this could mostly be due to connectivity issue between Eventlog Analyzer server and the SMTP Server.
Kindly check the connectivity between the SMTP Server and Eventlog Analyzer server.
Look out for any network firewall level restriction that could potentially prevent the connections.
Once you have identified the restriction, you may run either the test-netconnection or the send-mailmessage command to validate the connectivity.
When the email server could not be resolved by the hostname, customers can be suggested to check the DNS Server entries for the record. After the DNS Entry related issue is rectified, the connection to SMTP Service will be successful.
When the supplied credentials is incorrect/Invalid or the -credential parameter could be missing in the powershell Send-MailMessage command.
If the test email was sent successfully via Powershell script please proceed to next step.
2. Check for error races in the UI of Eventlog Analyzer
- Based on the error trace displayed in the UI, most of the mail server configuration errors shall be troubleshot.
For example, most common errors related to configuration are as follows.
The SMTP Server may not support basic authentication
The user account provided for the authentication purpose may not have send as permission for the user account specified in the From address
Incorrect security protocol chosen (TLS/SSL/None)
Depending on the security protocol supported by the SMTP Server, the appropriate one can be chosen.
For example, in the Serverout, the below-mentioned error traces can be found.
Must issue a STARTTLS command first
javax.mail.MessagingException: Could not convert socket to TLS;
Unrecognized SSL message, plaintext connection
The user credentials were incorrect
Error: authentication failed and Authentication unsuccessful
Application-specific password required
Invalid client secret value supplied
It is required to choose the correct client secret value.
For Microsoft, the client secret value is available under the value column as depicted below.
API Mail service related cases:
Connectivity to the API Endpoints is not available.
In this scenario, it is required for the Eventlog Analyzer server to have access to the Internet
Microsoft Endpoints are listed in this article, customers shall add the exclusion to the firewall. Google Workspace related API Endpoints are included in this article.
Insufficient API Scope Permission
This happens when the API Scope given does not match the scope recommended by Eventlog Analyzer.
For Microsoft, it is required for the API Application to be given "Mail.Send" permission with Admin Consent.
Related topics and articles
How to reach support
If the startup issue persists in spite of following the above steps, contact our support team here.
Support Channels:
Toll-Free (US): +1 844 649 7766