Upgrade failure caused by duplicate email addresses

Upgrade failure caused by duplicate email addresses

Error traces:

Exception occured while executing...
Sep 4, 2023 3:08:31 PM  [SYSERR]  [INFO] : java.sql.BatchUpdateException: Violation of PRIMARY KEY constraint 'RequestNotification_Recipients_PK'. Cannot insert duplicate key in object 'dbo.RequestNotification_Recipients'. The duplicate key value is (1925337, ).
Sep 4, 2023 3:08:31 PM  [SYSERR]  [INFO] : at com.microsoft.sqlserver.jdbc.SQLServerPreparedStatement.executeBatch(SQLServerPreparedStatement.java:2065)
Sep 4, 2023 3:08:31 PM  [SYSERR]  [INFO] : at com.zoho.cp.WrappedPreparedStatement.executeBatch(WrappedPreparedStatement.java:185)
Sep 4, 2023 3:08:31 PM  [SYSERR]  [INFO] : at com.adventnet.db.api.RelationalAPI.executeBatch(RelationalAPI.java:965)
Sep 4, 2023 3:08:31 PM  [SYSERR]  [INFO] : at com.adventnet.persistence.DataAccess.executeBatch(DataAccess.java:3203)
Sep 4, 2023 3:08:31 PM  [SYSERR]  [INFO] : at com.adventnet.persistence.DataAccess.executeBatch(DataAccess.java:3187)
Sep 4, 2023 3:08:31 PM  [SYSERR]  [INFO] : at com.adventnet.persistence.DataAccess.insertRows(DataAccess.java:3106)
Sep 4, 2023 3:08:31 PM  [SYSERR]  [INFO] : at com.adventnet.persistence.DataAccess.add(DataAccess.java:349)
Sep 4, 2023 3:08:31 PM  [SYSERR]  [INFO] : at com.adventnet.persistence.DataAccess.add(DataAccess.java:292)

Cause: 

There are duplicate email addresses for the same draft with different cases (e.g., abc@mail.comABC@mail.com).

Note: 
We recommend taking a full backup before and after applying the below workaround.

Workaround:

>> Connect the server to DB, execute the below query, and export it as a file for reference.

select * from drafts;

>> Execute the below query to unify the email addresses.

 update drafts set toaddress=lower(toaddress),cc=lower(cc);

 and repeat step 1.

>>  The PPM files can be applied after the successful execution of the above queries .

                    New to ADSelfService Plus?

                      • Related Articles

                      • Upgrade failure to 10500 - Linux platforms

                        You may experience an upgrade failure in linux platforms when upgrading to 10500. Here are the traces from logs, Feb 21, 2020 4:55:03 PM  [com.adventnet.tools.update.installer.Unzipper]  [SEVERE] : ERRUnexpected Error. Please click View Log>> for ...
                      • Requests duplicated - Not deleted from inbox after fetching

                        Issue When emails are fetched as requests, the application places a delete flag which is delete the email from the inbox. In this case, the emails are not deleted allowing the application to fetch the same email again and again  Cause  Issue occurs ...
                      • 10.5 Linux Upgrade failure and solutions

                        Traces in logs : 1. java.lang.Exception: InitPgsqlScript exited with value :: 1 at com.adventnet.persistence.PostgresPreProcessor.executeInitPgsqlScript(PostgresPreProcessor.java:1733) 2. PGSQL Permission related errors. 3. SDP MSP installed as root ...
                      • Upgrade failure from 1420X to 14300.

                        Error trace: 5 Sep, 2023 6:08:56 PM [com.adventnet.tools.update.installer.Unzipper] [INFO] : lib/phantomjs/linphantomjs/phantomjs 25 Sep, 2023 6:08:56 PM [com.adventnet.tools.update.installer.Unzipper] [SEVERE] : ERR:Exception while writing ...
                      • SDP MSP solution for postgres 11 upgrade issues

                        When ServiceDesk Plus MSP is upgraded to 14300 or later, postgres is also upgraded to 11.17. If you are using bundled postgres, data migration through pgdump and restore mechanism also happens. To ensure efficiency in Postgres 11.17, make sure your ...