Startup issues on Windows
- The most common issues with the service startup are the key file not being present in the correct path and folder permissions being incorrect. Check the PAM360/logs/wrapper.log file and you will see the root cause.
- If you see the error regarding key file not present, then request the customer to copy the pmp_key.key/pam360_key.key file from conf directory to any other directory of their choice. Then supply its full path in conf/manage_key.conf file. The full path should contain the file name at the end. For example, E:\MasterKey\pam360_key.key.
- If you the error "Trying to start postgreSQL failed", then it is a permission issue with the pgsql folder. In that case, ask the customer to open CMD with admin rights and run the below command.
- icacls "(PAM360 installation directory)" /grant PAM360serviceaccountname:(OI)(CI)F /T
- For example, icacls "C:\Program Files\ManageEngine\PAM360" /grant PAM-svc@domain.com:(OI)(CI)F /T
- Or, icacls "C:\Program Files\ManageEngine\PAM360" /grant DOMAIN/PAM-svc:(OI)(CI)F /T
- Then delete the old logs from logs directory and start the service.
- Sometimes, customers try to start the service using Tray Icon and it generally does not run with admin rights. So they will see the below error. In such case, exit tray icon, go to PMP/PAM360 folder, right-click PMP/PAM360.exe and select "Run as Admin". This will get the tray icon working fine. Also you can go to Properties of this file and set it to run as admin always.
