(OR)
- home/cener/ManageEngine/ServiceDesk/pgsql/bin/pg_ctl -w -D /home/cener/ManageEngine/ServiceDesk/pgsql/data -o "-p65432" start ]
- 27-feb-2024 15:53:28 [pglog] [INFORMACIÓN] : su: atención: no se puede cambiar el directorio a /home/cener/ManageEngine/ServiceDesk/pgsql: Permiso denegado
- 27-feb-2024 15:53:28 [pglog] [INFORMACIÓN] : -sh: 1: /home/cener/ManageEngine/ServiceDesk/pgsql/bin/pg_ctl: Permission denied
cause :
For the successful startup of the PostgreSQL server, several files needs to be accessed such as files under "<product_installation_home>\pgsql". particularly <product_installation_home>pgsql\data , <product_installation_home>\pgsql\ext_conf, <product_installation_home>\ tools folders. If the user who is trying to start the database is unable to access these files, then we could face the above exception.
In the past cases we encountered, most of this issue is due to the invalid permissions configured for that particular user, which gets resolved after providing necessary permissions.
Reference : SD-119253
resolution :
- Open a command prompt as the user, with whom you had installed the application. Or, with the user who you would like to start the application service. Or, with the user who you would like to invoke upgrade.
- Execute <product_installation_location> \ bin \ initPgsql script,
- If the script executes without any issue, you can good to proceed with your required operation.
If you face any failures, ensure whether the permissions are configured in a proper way in your operating system. Some of the previously encountered cases,
scenario 1 : If the permission denied error occurs when triggering an upgrade, but server starts successfully as service.
- The user configured with service is different from the user who triggered the upgrade in command prompt. The user configured in service has permission, whereas the user logged in to the command prompt doesn't.
- You can resolve this by either try with the user who is running the service or providing proper permissions to the user who invoke the upgrade in command prompt.
Case 2 : Database/Server machine crash lead to corrupted Database