Log Trace :
1:36:32:641]|[01-10-2024]|[com.manageengine.servicedesk.mailutils.ModuleHandler]|[INFO]|[277]: module identified : null|
[11:36:32:641]|[01-10-2024]|[com.manageengine.servicedesk.v3api.utils.InlineImageUtil]|[SEVERE]|[277]: text/plain - This file type is not supported|
[11:36:32:641]|[01-10-2024]|[com.manageengine.servicedesk.mail.core.MailScheduleBean]|[INFO]|[277]: __errormail__ : Error Mail is encountered for the first time. Skipping it to process again|
[11:36:32:641]|[01-10-2024]|[com.manageengine.servicedesk.mail.core.fetcher.MailFetcher]|[SEVERE]|[277]: __errormail__ : Error while processing inline image|
Cause :
In some cases, an inline image is received which has content-type apart from the regular Inline image content type. Say for example, some inline images have "text/plain" content-type (which can cause same errors in other email clients too) instead of "image/*" content type. Due to this, our internal validation of Inline Image, will cause failures in fetching that mail.
Fix :
Such problematic Inline images are stripped, and those exceptions are ignored (will print traces in logs) thereby Mails will be fetched successfully.