Mail Fetching Failure due to Invalid Inline Image embedded with Invalid MimeContent

Mail Fetching Failure due to Invalid Inline Image embedded with Invalid MimeContent


Log Trace :

1:36:32:641]|[01-10-2024]|[com.manageengine.servicedesk.mailutils.ModuleHandler]|[INFO]|[277]: module identified : null|
[11:36:32:641]|[01-10-2024]|[com.manageengine.servicedesk.v3api.utils.InlineImageUtil]|[SEVERE]|[277]: text/plain - This file type is not supported|
[11:36:32:641]|[01-10-2024]|[com.manageengine.servicedesk.mail.core.MailScheduleBean]|[INFO]|[277]: __errormail__ : Error Mail is encountered for the first time. Skipping it to process again|
[11:36:32:641]|[01-10-2024]|[com.manageengine.servicedesk.mail.core.fetcher.MailFetcher]|[SEVERE]|[277]: __errormail__ : Error while processing inline image|


Cause :
      In some cases, an inline image is received which has content-type apart from the regular Inline image content type. Say for example, some inline images have "text/plain" content-type (which can cause same errors in other email clients too) instead of "image/*" content type.  Due to this, our internal validation of Inline Image, will cause failures in fetching that mail.


Fix :
     Such problematic Inline images are stripped, and those exceptions are ignored (will print traces in logs) thereby Mails will be fetched successfully.

Steps to apply the fix
      Note :  Before applying the .fjar file, kindly verify its compatibility in the "Jar Compatibility" section below.
  1. Download the attached .fjar file.
  2. Click here for steps to apply the .fjar file.
  3. Restart the application service.
  4. Check for the issue.
  5. 5. If the issue occurs again, enable the email debug in the application, recreate the issue after enabling the email debug then immediately zip the logs (<server_home>\logs folder. For eg: C:\Program Files\ManageEngine\ServiceDesk\logs folder) and share it with us for analysis. If the size of the log file is huge, you can send it to us using our FTP link https://bonitas2.zohocorp.com/. Select the product as "ServiceDesk Plus" and provide the proper ticket number.

Jar Compatibility : 14505 - 14600
Reference Issue ID : SD-115664


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