SDP MSP 10526 Released and Announcement on Remote AE Behavior changes

SDP MSP 10526 Released and Announcement on Remote AE Behavior changes

Dear User(s)

Greetings for the day. We released ServiceDesk Plus MSP - version 10.5 - Build - 10526.


In continuation to this post, please refer to the below Announcement on Remote AE Behavior changes in this release.

With this release, we are replacing the existing AE agent used in Remote Asset Explorer(RAE - Distributed scan) with a Desktop Central agent.
Agent-based scanning can no longer be initiated directly from ServiceDesk Plus MSP. All agents need to push data via Remote AE servers only.

Changes due to DC Bundle in RAE installation:
  • AE agents used for scanning Windows machines are replaced with Desktop Central agents.
  • WMI scan (used for Windows machines) and SSH/Telnet scan (used for Linux and Mac machines) are no longer supported.
  • Linux and Mac machines should also be scanned using the new Desktop Central agent.
  • The script-based scanning used to scan devices outside your domain/network is no longer supported.
  • Removed the "MAC Address identification during scan" configuration from scan settings.
  • Removed the option to choose machines for remote control prompt. However, you can enable/disable the remote control prompt for all machines under Admin >> Agent Configuration.
  • Removed "WMI Timeout" and "Automatic Delta Scan" configurations from scan settings.
  • Configuring TCP protocols and ciphers are no longer supported.
SDPMSP-16084: Basic authentication has been replaced with API Key-based authentication for pushing data from a remote server. Hence RAE needs to reconfigure to make the scan work with this SDP MSP installation.

Behavior changes :
SDPMSP-16085: The use of AE agents for scanning Windows machines is no longer supported.
Note: You need to upgrade your Remote AE server as older versions are no longer supported. You can use the PPM path as mentioned - to upgrade RAE instance. 6500>> 6600>> 6700>> 6800>> 6900

Issues Fixed:
SDPMSP-16167/CVE-2021-20081: Remote Command Execution vulnerability in custom schedules reported by Chris.

Please do the upgrade only in a test environment first and based on the result please do the upgrade on the Production environment. You can contact our support at support@servicedeskplusmsp.com for any assistance. 

Following is the support policy of ServiceDesk Plus MSP :

  • Product support will be offered only for builds that are one year old. To continue receiving support, you will have to move to the latest version of ServiceDesk Plus MSP.
  • Service packs released will be applicable only over the latest available build of ServiceDesk Plus MSP.
  • We stopped MYSQL Database support.
  • Support for Servlet API is stopped.
  • Unpublished V3 API support is not available.

We stopped support for builds lesser than 10.5 (Build - 10500).  Hence we request our users to upgrade their instance to get further support.

Why upgrade?

By upgrading to the latest version, you get access to the new features that help improve your help desk performance and enhance IT service delivery. With every release, existing bugs are fixed, thus reducing the number of issues or breakdowns you experience with ServiceDesk Plus MSP.

Thanks for your continuous support

Santhosh
Head Of Service Delivery
ManageEngine ServiceDesk Plus MSP Team