Community and Support
            Knowledge Base ServiceDesk Plus - MSP Known Issues and Fixes Admin Account Details - Requesters

            Linux upgrade failure from 9400/9401 - Warning error (Applicable for 64 bit builds alone)

            Linux upgrade Known issue and its workaround.

            Users from 9400/9401 build will get the below error message while applying patch.

            Java HotSpot(TM) 64-Bit Server VM warning: You have loaded library /home/sdp-team/9300backup/9401/lib/native/libDiscSpace.so which might have disabled stack guard. The VM will try to fix the stack guard now.
            It's highly recommended that you fix the library with 'execstack -c <libfile>', or link it with '-z noexecstack'.
            Unable to load Disk Space related native library.
            Exception in thread "Thread-1" java.lang.UnsatisfiedLinkError: com.adventnet.tools.update.installer.DiskSpace.getFreeSpace(Ljava/lang/String;)J
                    at com.adventnet.tools.update.installer.DiskSpace.getFreeSpace(Native Method)
                    at com.adventnet.tools.update.installer.ApplyPatch.run(ApplyPatch.java:152)
                    at java.lang.Thread.run(Unknown Source)

            Do you want to continue ?


            FIX:

            Add the below property in updatemanager.sh  and try to upgrade.

            -Dsun.zip.disableMemoryMapping=true -Dtools.discSpaceCheck=false


            fyi:It is not the upgrade failure its just a warning error.Application will start even after this warning message.


            Helpful?  
            Help us to make this article better
            1 0