When updating a service pack or a patch, I get this message - "The ppm file that you have specified is not compatible with this product". What should I do?

When updating a service pack or a patch, I get this message - "The ppm file that you have specified is not compatible with this product". What should I do?

Service packs from Applications Manager are in the form of a .ppm file. The Update Manager has some useful validation incorporated related to this. This validation includes compatibility checks. You cannot use update manager to install an incompatible service pack. For example, you cannot install a service pack of another product in Applications Manager or a service pack of one version of Applications Manager in another version.


Note

If you have downloaded full build, do not install Service pack of the same version. For eg, if the full build no. is 6600, you will have SP6 in the service pack page. That service pack is for customers who have downloaded previous versions of full build like 6050, 6055 etc., By applying service pack SP6, the customers can upgrade themselves to 6600.