Unable to start or access the application after upgrading to 4600 or 4610

Unable to start or access the application after upgrading to 4600 or 4610

Issues:

Unable to start or access the application after upgrading to 4600 or 4610 version.

Case 1:
The application fails to start.

Case 2:
The application is started successfully but couldn't access the UI.

Root cause:

A few files were missing in the instance which is responsible for accessing/starting the application successfully

This case occurs only in a windows environment.

Case 1 error trace:

Trying to start PostgresSQL server failed 
INFO   | jvm 1    Problem while Starting

Trace to be checked on the wrapper log under <AnalyticsPlus home>\logs\wrapper

Case 2 error trace:
Caused by: java.io.IOException: Keystore was tampered with, or password was incorrect
at sun.security.provider.JavaKeyStore.engineLoad(JavaKeyStore.java:780)
at sun.security.provider.JavaKeyStore$JKS.engineLoad(JavaKeyStore.java:56)
at sun.security.provider.KeyStoreDelegator.engineLoad(KeyStoreDelegator.java:225)
... 25 more
Caused by: java.security.UnrecoverableKeyException: Password verification failed
at sun.security.provider.JavaKeyStore.engineLoad(JavaKeyStore.java:778)
... 35 more

Trace to be checked on the serverout_(today's date) log under <AnalyticsPlus home>\logs\serverout_(today's date)

Note: Where (today's date)  to be denoted by server's current date right next to the file name serverout_.

Example: serverout_2021-04-27.txt

Solutions: 

Case 1: 

Step 1: Log on to the installed server of Analytics plus

Step 2: Navigate to the below path

<AnalyticsPlus home>\conf\wrapper.conf


Step 3: Open the file and please add the below entry if it is missing at the end of the line.

set.PATH=../lib;%PATH%




Step 4: Save the file and start the  Analytics plus service.

Case 2:

Step 1: Log on to the installed server of Analytics plus

Step 2: Navigate to the below path

<AnalyticsPlus home>\conf\server.xml

Step 3: Open the file and please add the below parameter right before the 'scheme' param inside the "<<!-- Define a non-SSL Coyote ...." title tag as shown in the below picture.

protocol="com.adventnet.zoho.db.onpremise.session.KeystorePassDecryptor"





Step 4: Save the file and restart the Analytics plus service






                  New to ADSelfService Plus?

                    • Related Articles

                    • Unable to access the console in build 5120

                      Issue: Unable to access the console in build 5120 After upgrading Analytics Plus to build 5120 or fresh installation of build 5120, upon trying to login to the application, the page next to login screen would not load. Would throw the below error. ...
                    • Unable to access Analytics Plus after installation

                      Issue:  Unable to access Analytics Plus after installation even though the wrapper logs are fine. Analysis: There is a space character after the port number in the URL construction. Log Traces: java.lang.IllegalArgumentException: Invalid uri ...
                    • Auto start Analytics Plus in Linux

                      Steps to auto start Analytics Plus in Linux environment:     1. Open "StartServer.sh" present in <AnalyticsPlus\bin> Add  '#!/bin/sh' as the first line of the code. Add  'cd <location to Analytics/bin>' before the line 'sh run.sh'  ex : ...
                    • Unable to Access Analytics Plus in 3600/3700

                      Issue: You may unable to access Analytics Plus console when your default web server port is set to 443. It's identified as a bug which would affect both the existing and new users on builds 3600/3700. Cause: The builds 3600 and 3700 has an issue with ...
                    • Unable to install Analytics Plus in Linux VM's

                      During installation in console mode, most of the Linux(VM) users are experiencing issues with port check and they are unable to proceed. To avoid this, please use ISS or UI based installation option.  Error trace: Ports are occupied  Follow the below ...