Analytics Plus not accessible in iPad
Issue: Unable to launch AnalyticsPlus in iPad
If a customer tries to launch AnalyticsPlus in an iPad, after entering the credentials the screen will be stuck in loading data.
Cause:
The issue occurs as few security changes were not enabled in the URLs used for the Mobile App.
SOLUTION:
Please follow the below steps in the customer setup.
- Open the file <AnalyticsPlus_home>/webapps/ROOT/WEB-INF/securityxmls/security-zrop.xml
- Search for the string apiscope="mobileapi" and replace them with apiscope="reportsapi"
- Search for the string antisamyfilter_mproxy and replace them with antisamyfilter_reports_mail
- Restart the services and then try connecting in iPad.
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