Troubleshooting the "NumberFormatException" due to Locale Standards in APM Insight

Troubleshooting the "NumberFormatException" due to Locale Standards in APM Insight

Issue Summary:
The application throws a "NumberFormatException" when parsing numbers formatted with a comma (",") as a decimal separator (e.g., French - fr_FR, German - de_DE, Italian - it_IT). This occurs because the system expects numbers to be formatted with a dot (".") as a decimal separator, as per English (en_US) locale standards.

Example Exception:
  1. [3 juin 2024 16:04:14][/api/v2/apminsight/app/10011615/comp/details/graph/rtbycomponents/hH-1717430654437_###_https-jsse-nio-8443-exec-34-352][GRAVE](APMInsightBaseAPI.logApiError):Exception occured while processing api request.
  2. java.lang.NumberFormatException: For input string: "28,0"
  3. at sun.misc.FloatingDecimal.readJavaFormatString(FloatingDecimal.java:2043)
  4. at sun.misc.FloatingDecimal.parseDouble(FloatingDecimal.java:110)
  5. at java.lang.Double.parseDouble(Double.java:538)
  6. at com.manageengine.apminsight.common.util.StringUtils.getAsDouble(StringUtils.java:111)

Cause:
This issue arises due to a mismatch between the application's locale (e.g., French - fr_FR, German - de_DE, Italian - it_IT) and the expected locale of the system (English - en_US).

Workaround:
1. Update Locale Settings: Add the following configuration to the <AppManager>/conf/AMServer.properties file:
Info
am.server.language=en  
am.server.country=US  
2. Restart Applications Manager: Restart the AppManager service to apply the changes.
3. Check the APM tab for any recurring issues after the update.

Notes
Note: 
This issue was fixed in Applications Manager v173500. Upgrading to this version or later eliminates the need for the workaround.

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