Sync issue between SDP MSP and Aplus
Issue:
Sync fails between ServiceDesk Plus MSP and AnalyticsPlus, after upgrading the SDP to 14730.
Cause:
An example of a case mismatch issue is when Analytics Plus seeks column alias names such as BillID, but MSP returns BILLID instead. This is a flaw in the SDP code-level changes.
Error Trace:
[11:20:45:051]|[07-02-2024]|[com.manageengine.zrmeinteg.framework.ZRSDPFrameWorkImpl_1]|[INFO]|[132]: Generating CSV File...|
[11:20:48:630]|[07-02-2024]|[com.manageengine.zrmeinteg.framework.ZRSDPFrameWorkImpl_1]|[INFO]|[132]: Exception occured while advanced analytics data upload|
java.lang.Exception: No select column(s) found.
As the changes are being done in the SDP installed directory, If this error arises we need to forward this case to the SDP team to perform the below action.
Reference: (Action done by SDP to resolve the issue):
* Update the pkcolumn name from BILLID to BillID ( as shown in the below images) in the ZRMEModules.xml file under <ServiceDesk MSP Home>/ zreport/1/sync/conf .
1) From BILLID
2) To BillID
* Restart the SDP MSP service and initiate the sync for the changes to take .
Note:
The above issue will be fixed post SDP MSP 14730, in one of their upcoming hot fix.
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