Sync failure between ServiceDesk Plus and Analytics Plus

Sync issue in ServiceDesk Plus and Analytics Plus (after ServiceDesk Plus upgrade)

Issue:

After upgrading to the latest version of ServiceDesk the sync with Analytics might break halfway through with the below error msg. (Mostly when the Analytics is not upgraded)



Error Trace:
MESZ:Error is :: <nobr>[Line: 2,211 Field: 1] (-971) -ERROR: Invalid POSITIVE NUMBER value</NOBR><br><nobr>The data found at the row 2,211 has invalid data for the given configuration</NOBR><BR> 

Cause:
When the project module was introduced in 3800 (later reverted in 3900) the column's datatype was created in the template as 'Positive number'. 

But in the latest build (in A+ 3950) datatype of 'TimeSpent in Minutes' in the tables 'Status History','Technician History' and 'Support Group History' created as 'Number' datatype.


This issue is more likely to happen with Latest SDP (9422 and above).

Fix:

Follow the below steps to change the datatype to Number in the problematic tables. 

  Run the query "update zdbdbobjectprops set propvalue='false' where objid=<OBJID> and propkey='zdb.system.table'" by connecting database
  • Place the jar under AnalyticsPlus\lib
  • Restart the AnayticsPlus Service
  • Change the Datatype to 'Number' in the tables 'Status History','Technician History' and 'Support Group History'.
  • Run the query "update zdbdbobjectprops set propvalue='true' where objid=<OBJID> and propkey='zdb.system.table'" by connecting database
  • Stop the AnalyticsPlus service
  • Remove the jar
  • Start the AnalyticsPlus
  • Re-sync


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