Error message:
SSL certificate Error: An unexpected error occurred. Please contact support@admanagerplus.com
Possible causes:
The generated certificate might not have a private key installed.
The Subject Alternative Name (SAN) might not have been set or configured when generating the certificate.
Troubleshooting Steps :
When generating the SSL certificate, ensure that you include the private key along with the proper SAN name. You can access the SSL URL by generating it from the MMC console. For third-party certificates, you can request the vendor to include the private key on the certificate.
If configuring other certificate types such as .CRT or .CER, ensure that you have the ROOT CA certificate uploaded as well in the GUI interface.
You can import the SSL certificate generated in the MMC console in your AD environment and export the same SSL to try configuring it in AD Manager Plus.