Issue:
In some cases, even after configuration and enabling of SAML option, it does not appear in the login page. However, if you notice in login page customization, the SAML option appears.
Root cause:
Check SAML - Service provider details. Assertion Consumer and Single Logout Service URLs would be in HTTP whereas application would be running in HTTPS. This is because the environment has HTTPS redirection enabled in the network/server like Nginx (and not in the product) due to which our application shows as HTTP.
Fix:
Check Admin->Security Settings. It would be set in HTTP. Educate the customer and change webserver to HTTPS and restart the application. Now check the service provider details, it would appear in HTTPS and also SAML option would be visible in the login page.
If this does not work, please check TrayIconInfo.xml file under ManageEngine\Servicedesk Plus MSP\Conf and manually update as HTTPS as shown below and restart.
Note : Even if the protocol is updated as HTTPS under Trayiconinfo.xml and under Security setting as recommended but still SAML not getting reflected on login screen. Change the application to HTTP any random port using ChangeWebserverport and revert to HTTPS 443. This will get the SAML on login screen again. Try reconfiguring SAML if required and verify the status.