Steps to perform Repopulation for sync issue
Symptoms:
[SYSERR]|[INFO]|[61]: java.lang.NullPointerException|
[SYSERR]|[INFO]|[61]: at com.manageengine.framework.sqlbuilder.AQBManager.updateColumnDetailCache(AQBManager.java:488)|
Cause:
The mismatch between ZRMEModules.xml and SDP UI.
Workaround:
- Need to repopulate the ZRMEModule.xml file
- In CMD with admin access need to run the repopulation tool.
- Please restart the ServiceDesk Plus service
For MSP customers:
- Run the repopulation tool
- Replace <MSP Home>\zreports\sync\ZRMEModules.xml with the attached file(This Step is not necessary for SDP customer, only for MSP customer)
- Restart the SDP and try the sync
New to ADSelfService Plus?
Related Articles
Sync issue between SDP MSP and Aplus
Issue: Sync fails between ServiceDesk Plus MSP and AnalyticsPlus, after upgrading the SDP to 14730. Cause: An example of a case mismatch issue is when Analytics Plus seeks column alias names such as BillID, but MSP returns BILLID instead. This is a ...
Sync getting stuck in In-progress state
Issue: Sync getting stuck in In-progress state. Usually, when the data type mismatch is present, this issue occurs. Logs required: <AnalyticsPlus>/pgsql/data/pg_log/ Check for the error trace by searching "ERROR: invalid input syntax for" Sample ...
Unable to sync between Servicedesk Plus and Analytics Plus - ATKey error
Issue: Unable to configure integration/sync between ServiceDesk Plus and Analytics Plus ERROR Message: FAILURE :Not able to get ATKey from Server. You can obtain the error log files from Support tab by clicking on the Support File link in the ...
Sync issue in ServiceDesk Plus and Analytics Plus (after ServiceDesk Plus upgrade)
Issue: After upgrading to the latest version of ServiceDesk the sync with Analytics might break halfway through with the below error msg. (Mostly when the Analytics is not upgraded) Error Trace: MESZ:Error is :: <nobr>[Line: 2,211 Field: 1] (-971) ...
Upgrade Key steps
Key steps that must be followed without which the upgrade may fail. All Analytics Plus Services must be stopped. AnalyticsPlus folder must be given "Everyone" folder permission with "Full Control" before upgrade (Can be revoked after upgrade) ...