Issue :
New request is created everytime when a user is sending mail to closed or Resolved Request.
Cause :
In some cases, there will be no workorder id mentioned in the subject and that mail is not sent as reply from user for the notification or reply mail sent from user, But they need to be added as conversation.
In such cases, Parent WorkOrderID is found by using References Header mentioned in the mail.Currently, while fetching a list a workorders it is sorted as ascending order, so the old request is considered.
Resolution :
This issue can be resolved by considering the Latest Workorder created using that references header.
Steps to be Followed :
- Download the attached fjar.
- place the fjar in <product_home>/'fixes' directory. if the directory is not exist, kindly create one.
- Restart the application.