Mail sending failed_Unable to relay

Mail sending failed_Unable to relay

Error trace in logs:

javax.mail.SendFailedException: Invalid Addresses;nested exception is: com.sun.mail.smtp.SMTPAddressFailedException: 550 5.7.1 Unable to relay

Possible Cause:

  1. The SMTP server does not allow relaying unless you are sending email from a trusted IP or use proper authentication.
  2. Microsoft Exchange server: server is setup to block SMTP relaying.
  3. Some servers allow you to send email internally but not to external email addresses.
  4. Some SMTP servers require the Email User to login and check their POP3 email at least once on the given IP before they let that user send SMTP mail from that IP. Once the POP3 email is checked using a valid user/password, the computers IP is then automatically added to a safe list on the server. This is another way to prevent spam.
  5. Relaying denied is a common safety measure used by SMTP servers when a certain email address and its mail server are put on a blacklist for email relay spam violations. Many honest mail servers get put on this list because someone broke through and used their server to relay spam. There are various blacklists available and SMTP servers may subscribe to none, a few or many of these lists. Hence you may be able to send email to a blacklisted address through one SMTP server but not through another.

Solutions:

  1. Make sure with your email administrator that your email server is setup to allow SMTP relaying from trusted local internal IP addresses.
  2. Make sure that your computers IP address is on the list of trusted clients on the email server.
  3. Some email servers may allow relaying only if you log in and check email at least once from a given IP address. In this case, you can check your POP3 email first before sending SMTP email from a new computer.
  4. Some email servers allow SMTP relaying only if you log in and check email within the last 1 hour per day and so on. In this case, you should use the pop3 authentication method to send email.
  5. Some servers require you to authenticate before sending email. In this case, use the SMTP or java authentication method.
  6. Microsoft Exchange: make sure that your exchange server is configured to allow SMTP relaying either for trusted IP addreses or for users that are authenticated.

 


                  New to ADSelfService Plus?

                    • Related Articles

                    • List of mail fetching issues and solutions

                      Scenario 1 : Mail fetching issue due to Invalid or No PKIX certificate .   Log traces for Mail Fetching  issues Exception when connecting to store.|javax.mail.MessagingException: sun.security.validator.ValidatorException: PKIX path building failed: ...
                    • Mail fetching failed - PKIX path building failed.

                      Cause: If the SSL Certificate in mail server is a self signed certificate then it is not imported in the ServiceDeskPlus-MSP java environment while using the POPS/IMAPS protocol. Error Trace in logs: javax.net.ssl.SSLHandshakeException: ...
                    • Sending notification failed

                      In some scenarios the outgoing emails will error with Sending notification failed message in UI and in the logs you can see, 550 5.2.125 The sender has exceeded the maximum number of messages they are allowed to send via client submission either per ...
                    • Mail sending failed_ Unrecognized SSL message, plaintext connection?

                      Log error trace: Caused by: javax.mail.MessagingException: Could not connect to SMTP host: smtp.office365.com, port: 587;   nested exception is: javax.net.ssl.SSLException: Unrecognized SSL message, plaintext connection? Solution: Error trace means ...
                    • Fix: Error while sending mail using EWS

                      Issue trace: [11:58:49:091]|[11-29-2022]|[SYSERR]|[INFO]|[122]: microsoft.exchange.webservices.data.core.exception.service.remote.ServiceResponseException: The operation can't be performed because the item is out of date. Reload the item and try ...