Live Chat Doesn't work Outside the server

Live Chat Doesn't work Outside the server

Issue:

Live chat function works on the MSP server i.e. works only when tried on localhost, however does not work outside it. Same will be the case with Bell notification and Request collaboration features.

Cause:

This happens mostly on HTTPS where the NIO port should be allowed for secured connection as well.

Fix:

Take a backup of the server.xml file and place it on the desktop or a different folder. Kindly do not rename and place it in the same folder, as it may conflict.

 1. Edit server.xml file under \ManageEngine\ServiceDeskPlus-MSP\conf.

2. Search for the keyword "SSL Enabled" to find the HTTPS connector located.

3. Copy that complete connector and paste it just below.

4. In the copied connector, make the following changes.

a. Remove the parameter named Ciphers along with its values.

b. Update the NIO port number in the parameter named Port.

c. Add the below parameter named Protocol

protocol="org.apache.coyote.http11.Http11NioProtocol"

5. After the modifications, the file should look like below.



6. Once changes are done, restart the application and check the chat issue, that should work.
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