Imported data as invalid value, incorrect value, unknown value

Imported data in a column shows an incorrect value

Issue:

In Analytics Plus version 4100, when a data is imported into Analytics Plus(especially from MSSQL server), a few column values are not identified properly.  The query used to pull the details works fine on MSSQL server and returns proper results.

eg:



MSSQL otuput:



Cause:

The column was not identified as a valid data type so it is moved to 'unknown'

Solution:

The column identified as a unknown data type should be converted to string datatype. Here are the steps involved

  • Download the attached file(1MSSQL.jar) and place it under <AnalyticsPlus home>\lib
  • Restart the Analytics Plus service
Note: If you are using the other versions of Analytics Plus and experiencing the same issue, please write to analyticsplus-support@manageengine.com for further assistance.

                  New to ADSelfService Plus?

                    • Related Articles

                    • Change module data : Import into Analytics Plus

                      Change module data : Import into Analytics Plus Note: When Analytics Plus officially supports Change module integration Out of the box, then these imported tables and reports might get overwritten. Please ensure to name the table as 'Change_localDB'. ...
                    • Problem Module Data import

                      Importing Problem data into Analytics Plus:  You could log into the Analytics Plus 'ME ServiceDesk Plus Analytics' database and start creating these two tables using the below queries. Check this link for steps to import data from Local DB. Problem ...
                    • Workaround to add Region Field in Servicedesk plus data

                      With the out of the box integration, we don't bring 'Region' details from the ServiceDesk Plus. However, you can follow the below steps to import the region details into a new table 1. Import using Local Database by connecting to the Servicedesk Plus ...
                    • Importing Projects Module data into Analytics Plus

                      We are yet to sync 'Projects' module's data into Analytics Plus. Meanwhile, you can use custom queries to import those data from ServcieDesk Plus. Step 1: Login into Analytics Plus and open ServiceDesk Plus database. Step 2: Click 'Import Data' and ...
                    • How to import Survey data from ServiceDesk Plus to Analytics Plus?

                      Helpdesk surveys help you identify how happy your customers really are with your services. A recent research revealed that 96% of unhappy customers don't complain but, 91% of those unhappy customers leave and never come back. That is sad, isn't it?   ...