Imported data in a column shows an incorrect value
Issue:
In Analytics Plus version 4100, when a data is imported into Analytics Plus(especially from MSSQL server), a few column values are not identified properly. The query used to pull the details works fine on MSSQL server and returns proper results.
eg:
MSSQL otuput:
Cause:
The column was not identified as a valid data type so it is moved to 'unknown'
Solution:
The column identified as a unknown data type should be converted to string datatype. Here are the steps involved
- Download the attached file(1MSSQL.jar) and place it under <AnalyticsPlus home>\lib
- Restart the Analytics Plus service
New to ADSelfService Plus?
Related Articles
Change module data : Import into Analytics Plus
Change module data : Import into Analytics Plus Note: When Analytics Plus officially supports Change module integration Out of the box, then these imported tables and reports might get overwritten. Please ensure to name the table as 'Change_localDB'. ...
Problem Module Data import
Importing Problem data into Analytics Plus: You could log into the Analytics Plus 'ME ServiceDesk Plus Analytics' database and start creating these two tables using the below queries. Check this link for steps to import data from Local DB. Problem ...
How to import data using URL that consists special characters
Issue: Not able to import data using URL that contains special characters (for eg: http://my.domain.com:8080/~noname/examplefile.json) as they are not recognized by the application. Error Message: The parameter URL does not match the accepted input ...
Workaround to add Region Field in Servicedesk plus data
With the out of the box integration, we don't bring 'Region' details from the ServiceDesk Plus. However, you can follow the below steps to import the region details into a new table 1. Import using Local Database by connecting to the Servicedesk Plus ...
Steps to import approval date
We can fetch the approval date data from ServiceDesk Plus using the following workaround. Below are the steps to be followed to successfully import the data. Step 1: Click Import data within the ServiceDesk Plus database in Analytics Plus. Step 2: ...