How to troubleshoot when having error 'No data available' in Solaris Monitor in Telnet/SSH Mode

How to troubleshoot when having error 'No data available' in Solaris Monitor in Telnet/SSH Mode

Notes

Important Note:

  1. Establish a Telnet or SSH connection to the remote Solaris machine before proceeding.
  2. Use the same user account that is used for monitoring in the product to execute the following commands.

1. Disk Errors:

Command:
Quote
echo DISKERRORS_CMD_OP_ST;
export S_COLORS='never'; LANG=C iostat -en;
echo DISKERRORS_CMD_OP_END;
Steps:
  1. Connect to the Solaris machine: Ensure a stable Telnet or SSH connection.
  2. Execute the provided commands to check for disk error statistics (`iostat -en`).
  3. Verify if disk error data is displayed. If not, proceed to troubleshoot.
Troubleshooting Steps:
  1. Check connectivity and authentication.
  2. Verify `iostat` syntax and command execution.
  3. Ensure sufficient permissions for command execution.

2. Network Interface Utilization:

Command:
Quote
echo NETWORKINTUTIL_CMD_OP_ST; while read -r line; do interface=$(echo "$line" | awk '{print $1}'); state=$(/usr/sbin/dladm show-phys "$interface" 2>/dev/null | awk 'NR==2{print $3}'); speed=$(/usr/sbin/dladm show-phys "$interface" 2>/dev/null | awk 'NR==2{print $4}'); duplex=$(/usr/sbin/dladm show-phys "$interface" 2>/dev/null | awk 'NR==2{print $5}'); if [ -n "$state" ]; then echo "$line $state $speed $duplex"; fi; done < <(netstat -i | awk 'NR>2 && $1 !~ /^Name|^lo/ {if (!seen[$1]++) print $0}'); echo NETWORKINTUTIL_CMD_OP_END;

Steps:
  1.   Connect to the Solaris machine: Ensure Telnet or SSH connectivity.
  2.   Execute the command to check network interface utilization.
  3.   Verify if interface details are displayed. Proceed with troubleshooting if no data is shown.
Troubleshooting Steps:
  1. Validate network interface configurations (`dladm`).
  2. Ensure network interfaces are active and properly detected (`netstat`).
3. IP Address Status:

Command:

Quote

echo IPADDRSTATUS_CMD_OP_ST; /usr/sbin/ipadm show-addr | grep -v lo0; echo IPADDRSTATUS_CMD_OP_END;

Steps:
  1. Connect to the Solaris machine: Establish Telnet or SSH connection.
  2. Execute the command to display IP address configurations.
  3. Check if IP addresses excluding `lo0` are listed. Proceed to troubleshoot if no output is observed.
Troubleshooting Steps:
  1. Verify IP address assignments and configurations.
  2. Review and resolve any conflicts or misconfigurations.
4. IPMP Group Status:

Command:
Quote
echo IPMPGRPSTATUS_CMD_OP_ST; /usr/sbin/ipmpstat -gn; echo IPMPGRPSTATUS_CMD_OP_END;
Steps:
  1. Connect to the Solaris machine: Ensure Telnet or SSH connectivity.
  2. Execute the command to check IPMP group status (`ipmpstat -gn`).
  3. Verify if IPMP groups and their status are displayed. Proceed with troubleshooting if no data is shown.
Troubleshooting Steps:
  1. Confirm IPMP configurations and redundancy settings.
  2. Check for any failed or inactive IPMP groups.
5. HBA Port Status:

Command:
Quote
echo HBAPORTSTATUS_CMD_OP_ST; /usr/sbin/fcinfo hba-port; echo HBAPORTSTATUS_CMD_OP_END;
Steps:
  1. Connect to the Solaris machine: Establish Telnet or SSH connection.
  2. Execute the command to check HBA port status.
  3. Verify if HBA ports and their configurations are displayed. Proceed to troubleshoot if no data is shown.
Troubleshooting Steps:
  1. Ensure SAN connectivity and HBA configurations.
  2. Review zoning and storage area network (SAN) settings.
6. Multipathing Status:

Command:

Quote

echo MULTIPATHINGSTATUS_CMD_OP_ST; paste <(/usr/sbin/mpathadm list lu | grep -i "Total Path Count" | cut -d":" -f2) <(/usr/sbin/mpathadm list lu | grep -i "Operational Path Count" | cut -d":" -f2) <(/usr/sbin/mpathadm list lu | grep -i "dev/rdsk"); echo MULTIPATHINGSTATUS_CMD_OP_END;
Steps:
  1. Connect to the Solaris machine: Ensure Telnet or SSH connectivity.
  2. Execute the command to check multipathing status
  3. Verify total and operational path counts for multipathed devices (`dev/rdsk`). Proceed with troubleshooting if no data is shown.
Troubleshooting Steps:
  1. Validate multipath configurations (`mpathadm`).
  2. Check for any failed or inactive paths.
7. Zpool Status:

Command:
Quote
echo ZPOOLSTATUS_CMD_OP_ST; /usr/sbin/zpool list; echo ZPOOLSTATUS_CMD_OP_END;
Steps:
  1. Connect to the Solaris machine: Establish Telnet or SSH connection.
  2. Execute the command to check ZFS pool status (`zpool list`).
  3. Verify if ZFS pool names and their configurations are displayed. Proceed to troubleshoot if no data is shown.
Troubleshooting Steps:
  1. Review ZFS pool configurations and health status.
  2. Check for any errors or degraded pools.
8. Service Fault Status:

Command:
Quote
echo SVCSFAULT_CMD_OP_ST; svcs | grep -v "^online"; echo SVCSFAULT_CMD_OP_END;
Steps:
  1. Connect to the Solaris machine: Ensure Telnet or SSH connectivity.
  2. Execute the command to check service fault status (`svcs`).
  3. Verify if services not in an "online" state are listed. Proceed with troubleshooting if no data is shown.

Troubleshooting Steps:
  1. Investigate service dependencies and logs.
  2. Review and resolve any service failures.
9. System Fault Status:

Command:
Quote
echo SYSFAULT_CMD_OP_ST; /usr/sbin/fmadm faulty -s | awk '!/^/ && !/^TIME/ {event_id=$4; print $0}' | while read -r line; do event_id=$(echo "$line" | awk '{print $4}'); details=$(/usr/sbin/fmadm faulty -f | tr '\n' ' ' | awk '{print $2, $3, $4, $5}' | awk -v id="$event_id" '$1 == id {printf " %s %s %s", $2, $3, $4}'); echo "$line $details"; done;
Steps:
  1. Connect to the Solaris machine: Ensure Telnet or SSH connectivity.
  2. Execute the command to check system fault status.
  3. Verify if system faults and their details are displayed. Proceed with troubleshooting if no data is shown.
Troubleshooting Steps:
  1. Investigate hardware and software issues reported by `fmadm`.
  2. Review logs and system event details.
10. Chassis Status:

Command:
Quote
echo CHASSISSTAT_CMD_OP_ST; /usr/sbin/ipmitool chassis status; echo CHASSISSTAT_CMD_OP_END;
Steps:
  1. Connect to the Solaris machine: Ensure Telnet or SSH connectivity.
  2. Execute the command to check chassis status (`ipmitool chassis status`).
  3. Verify if chassis health and sensor readings are displayed. Proceed to troubleshoot if no data is shown.
Troubleshooting Steps:
  1. Check IPMI configurations and hardware sensor readings.
  2. Ensure environmental sensors are functioning properly.
11. Sensor Status:

Command:
Quote
echo SENSORSTATUS_CMD_OP_ST; /usr/sbin/prtdiag -v | awk '/Environmental Status/,/FRU Status/ {if ($0 !~ /FRU Status/ && $3 != "steady" && $3 != "enabled" && $3 != "ok") print}'; echo SENSORSTATUS_CMD_OP_END;
Steps:
  1. Connect to the Solaris machine: Ensure Telnet or SSH connectivity.
  2. Execute the command to check sensor status (`prtdiag -v`).
  3. Verify if environmental sensor readings and hardware status are displayed. Proceed to troubleshoot if no data is shown.

Troubleshooting Steps:
  1. Monitor environmental sensor



                  New to ADSelfService Plus?