Error: Pg_Ctl does not exist or being used by some other program

Error: Pg_Ctl does not exist or being used by some other program

Error Message: 

Pg_Ctl does not exist or being used by some other program

 

 

Possible Cause:

  1. This error message would appear if we do not have sufficient permissions to start up ADManager Plus or to upgrade it.

  1. This error message could also occur if any antivirus is blocking the user from starting the product.

  1. This error message would appear if Windows Defender or any third-party software may lock the files inside the ADManager Plus installation folder.

 

Solution:

  1. We will need to provide sufficient permissions in ADManager Plus for the user we are using (Service Account/Account that is logged in to the server).

  1. We can do this by navigating to the ADManager Plus Installation Drive:\ManageEngine\ADManager Plus\bin folder. From the bin folder, start the command prompt and type in "InitPgsql.bat".

  1. Once it's completed, we can then try to start/upgrade ADManager Plus.

  1. We will need to whitelist the ADManager Plus folder from the antivirus. Once that is done, we will need to restart the server for the AV settings to take effect, and then try to start ADManager again.

Note: Please ensure that none of the ADManager Plus processes are running within the server during these actions.

 

Other Possible Solution:


Navigate to ADmanager plus Installation Drive:\\ManageEngine\AMDanager Plus > Right click on the folder > select properties > click security > click Add > Add the account that you are logged in with on the server/Service account > Save.

 

 

 

 

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