Error message while performing database backup of Applications Manager

Error message while performing database backup of Applications Manager

While performing database backup operation of Applications Manager build with Pgsql backend, you may encounter the following error, especially when your database size has grown bigger with a large number of tables.

 

pg_dump: WARNING: out of shared memory
pg_dump: SQL command failed
pg_dump: Error message from server: ERROR: out of shared memory
HINT: You might need to increase max_locks_per_transaction.


Reference screenshot:


Cause

The error is caused by insufficient value of Max_locks_per_transaction parameter in the PostgreSQL.conf file. This parameter controls the average number of object locks allocated for each transaction. The default value of this parameter is 64. 


Solution

To overcome this error, perform the steps below:

 

  • Navigate to AppManager_Home\working\pgsql\data\amdb in your Applications Manager installation.

  • Uncomment the line #max_locks_per_transaction = 64 in the  postgresql.conf  file

  • Increase the value of max_locks_per_transaction to a higher value, eg. max_locks_per_transaction = 10000

  • Restart the Applications Manager.

  • Take backup of the database again.

 

 

 

 


                  New to ADManager Plus?

                    New to ADSelfService Plus?