Error: java.sql.SQLException: Cannot find the symmetric key 'ZOHO_SYMM_KEY', because it does not exist or you do not have permission.

Error: java.sql.SQLException: Cannot find the symmetric key 'ZOHO_SYMM_KEY', because it does not exist or you do not have permission.

Error Message:

java.sql.SQLException: Cannot find the symmetric key 'ZOHO_SYMM_KEY', because it does not exist or you do not have permission.

Possible Cause:

This issue could occur if there is any mismatch with master key.


Resolution:

A. For AD Manager Plus Build is 7100 and above:

 

1. Stop the product.

2. Take a back up of "conf/customer-config.xml" and update the existing property inside <configuration name="mssql" > as given below

<property name="masterkey.password" value="YOUR_PASSWORD_HERE" />
3. Add new property inside <configuration name="mssql" >

<property name="masterkey.open" value="true" />

Note: Click here to know more on how to generate master key.
4. Replace 'YOUR_PASSWORD_HERE' with the password obtained from your SQL server.

5. Save the file and try migrating the database with ordinary steps.


B. For AD Manager Plus Build below 7100:

1. Stop the product

2. Go to ADManager Plus folder -> conf -> persistance -> persistance-configuration.xml

3. Search for "<property name="sqlgenerator" value="com.adventnet.db.adapter.mssql.MssqlSQLGenerator"/>"

4. Below the searched line , paste the below lines,

<property name="masterkey.password" value="YOUR_PASSWORD_HERE" />

<property name="masterkey.open" value="true" />

5. Replace 'YOUR_PASSWORD_HERE' with the password obtained from your SQL server.

https://docs.microsoft.com/en-us/sql/t-sql/statements/create-master-key-transact-sql?view=sql-server-ver15

6. Save the file and try migrating the database with ordinary steps.

Note: The password should meet the MSSQL password complexity. For more information on Microsoft SQL complexity, please refer to this document.

If the problem still persists, contact support@admanagerplus.com


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