DataBackup settings in the Analytics Plus is unresponsive upon clicking

DataBackup settings in the Analytics Plus is unresponsive upon clicking

Issue: 
 Problem while restoring.

Cause: 
The"Data Backup" setting page will not be responsive when we select folder (backup directory) other than the AnalyticsPlus installation folder during the backup. This is a code-level issue. 

 Error trace:
[06:26:58:435]|[05-05-2023]|[com.adventnet.zoho.db.onpremise.settings.ZROPBackupSettingsUtil]|[WARNING]|[128]: Exception while getting backup config. Trace: |
java.io.IOException: The filename, directory name, or volume label syntax is incorrect
at java.io.WinNTFileSystem.canonicalize0(Native Method)
at java.io.WinNTFileSystem.canonicalize(WinNTFileSystem.java:428)
at java.io.File.getCanonicalPath(File.java:626)

   Solution: Place the fjar under "AnalyticsPlus/fixes" and restart the service.
 

Note :
Check the backup folder location using the below query

Select * from Default_Task_Input;

Note
This issue may arise from the 5130 to 5230 version. This will be fixed in the upcoming release.


                  New to ADSelfService Plus?

                    • Related Articles

                    • #9113995 - Debug

                      Issue: IMAP with TLS is working for the customer. However, it is not possible to configure IMAP with TLS in SDP app. Debug: Debug jar has been prepared to check which configuration works for the customer. Also, debug prints will be printed in the ...
                    • Apply Certificate for Office365 MailBoxes which is using OAuth for Authorization

                      User can configure O365 in both incoming & outgoing settings in SDP. To Connect mail server from SDP, its certificates should be available in SDP's Keystore. This document is for users who have applied internal CA Certificate for O365 OAuth ...