DataBackup settings in the Analytics Plus is unresponsive upon clicking

DataBackup settings in the Analytics Plus is unresponsive upon clicking

Issue: 
 Problem while restoring.

Cause: 
The"Data Backup" setting page will not be responsive when we select folder (backup directory) other than the AnalyticsPlus installation folder during the backup. This is a code-level issue. 

 Error trace:
[06:26:58:435]|[05-05-2023]|[com.adventnet.zoho.db.onpremise.settings.ZROPBackupSettingsUtil]|[WARNING]|[128]: Exception while getting backup config. Trace: |
java.io.IOException: The filename, directory name, or volume label syntax is incorrect
at java.io.WinNTFileSystem.canonicalize0(Native Method)
at java.io.WinNTFileSystem.canonicalize(WinNTFileSystem.java:428)
at java.io.File.getCanonicalPath(File.java:626)

   Solution: Place the fjar under "AnalyticsPlus/fixes" and restart the service.
 

Note :
Check the backup folder location using the below query

Select * from Default_Task_Input;

Note
This issue may arise from the 5130 to 5230 version. This will be fixed in the upcoming release.


                  New to ADSelfService Plus?