Calculation of various attributes in AIX server

Calculation of various attributes in AIX server

Page Space

Command: lsps -a

Sample Output:

Page Space      Physical Volume   Volume Group       Size       %Used       Active     Auto        Type       Chksum
---------------------------------------------------------------------------------------------------------------------------------------------------------------
hd6                         hdisk0                  rootvg               512MB           3            yes        yes            lv                0

where,
Psize=Size
Pused=%used

Memory

Command: LANG=en_US.UTF-8 lparstat 1 3

Sample Output:

System configuration: type=Dedicated mode=Capped smt=4 lcpu=16 mem=7648MB 

%user      %sys      %wait      %idle
--------------------------------------------------
   0.0         0.2          0.0         99.8 
   0.2         0.5          0.0         99.3 
   0.0         0.2          0.0         99.8 

CPU

Command: /usr/bin/vmstat 1 3

Sample Output:

System configuration: lcpu=16 mem=7648MB

kthr    memory              page              faults        cpu    
----- ----------- ------------------------ ------------ ---------------------------------------------------
 r   b   avm      fre           re  pi  po  fr   sr  cy  in      sy    cs    us  sy   id   wa
 0  0  611519  823889   0   0   0   0    0   0   176  215   197   0    0   99   0
 0  0  611519  823889   0   0   0   0    0   0   164   48   200  0    0   99   0
 0  0  611519  823889   0   0   0   0    0   0   121   61     195   0    0   99   0

where, 
UserTime=us
SystemTime=sy
WaitTime=wa
IdleTime=id
RunQueue=r
BlockedProcess=b
IntrsPerSec=in

To know more about how CPU Utilization is calculated, refer here.

CPU Core

Command: LANG=en_US.UTF-8 sar -u -P ALL 1 3

Disk Utilization

Command: /usr/bin/df -Ik

Sample Output:

Filesystem          1024-blocks            Used            Free             %Used       Mounted on
---------------------------------------------------------------------------------------------------------------------------------------------
/dev/hd4              210763776       10881972       199881804          6%             /
/dev/hd2                4718592         4265348          453244            91%             /usr
/dev/hd9var         105381888       3708900       101672988          4%             /var
/dev/hd3              105381888        3703684       101678204          4%             /tmp
/dev/fwdump       1048576            85808          962768                9%             /var/adm/ras/platform
/dev/hd1               210239488        5841968       204397520         3%             /home
/dev/hd11admin     24288               440                523848               1%             /admin
/proc                            -                     -                          -                      -                /proc
/dev/hd10opt        105381888        3209220       102172668          4%             /opt
/dev/livedump      524288             408                523880                1%             /var/adm/ras/livedump
/dev/zoholv           115343360        18072             115325288          1%             /zoho

Inode Usage

Command: /usr/sysv/bin/df -i

Sample Output:

Mount Dir                              Filesystem              iused              ifree                    itotal              %iused
--------------------------------------------------------------------------------------------------------------------------------------------------
/                                             /dev/hd4                75670            44463403         44539073            1%
/usr                                        /dev/hd2                46176            103344               149520                31%
/var                                        /dev/hd9var           8591             22595322          22603913            1%
/tmp                                       /dev/hd3                6142             22601109            22607251            1%
/var/adm/ras/platform          /dev/fwdump          34                213978                214012                  1%
/home                                    /dev/hd1                 4437            45430546          45434983             1%
/admin                                    /dev/hd11admin       5                116501                 116506                   1%
/proc                                       /proc                        0                    0                           0                       0
/opt                                         /dev/hd10opt        30354          22708123         22738477               1%
/var/adm/ras/livedump          /dev/livedump        4                116445                 116449                   1%
/zoho                                      /dev/zoholv            10               25627895         25627905              1%

Memory Utilization

Calculation: PhysicalMemUtilization % = (used/total)*100 

Command: svmon -G|sed 's/in use/in_use/g'

Sample Output:

                     size             inuse           free               pin           virtual    mmode
---------------------------------------------------------------------------------------------------------------
memory      1957888     1134182      823706      442339       611688     Ded
pg space     131072        3664

                     work              pers        clnt             other
---------------------------------------------------------------------------------------
pin                381763           0              0              60576
in_use           611688          0          522494

            PageSize         PoolSize         inuse           pgsp         pin            virtual
---------------------------------------------------------------------------------------------------------------
s              4 KB                     -            686406         3664       86099      163912
m            64 KB                   -             27986            0             22265      27986

Disk IO Stats

Command: iostat -d;echo '-----DISK_EXTENDED_STATS-----';iostat -d 1 3

Sample Output:

System configuration: lcpu=16 drives=4 paths=3 vdisks=0

Disks:        % tm_act     Kbps     tps    Kb_read         Kb_wrtn
-------------------------------------------------------------------------------------------
hdisk2           0.1             0.7        0.2    328631         9831332
hdisk1            0.0            0.4       0.1      321793         4742952
hdisk0           0.9            49.6     2.1     587563424   98041832
cd0                0.0             0.0      0.0         0                   0

-----DISK_EXTENDED_STATS-----

System configuration: lcpu=16 drives=4 paths=3 vdisks=0

Disks:        % tm_act      Kbps     tps    Kb_read   Kb_wrtn
-----------------------------------------------------------------------------------
hdisk2           0.0             0.0       0.0          0              0
hdisk1            0.0             0.0       0.0          0              0
hdisk0           0.0             0.0       0.0          0              0
cd0                0.0             0.0       0.0          0              0

Disks:        % tm_act     Kbps      tps      Kb_read   Kb_wrtn
-------------------------------------------------------------------------------------
hdisk2          10.0            16.0       4.0          0              16
hdisk1           0.0            20.0       5.0          0              20
hdisk0          10.0           220.0    53.0        0             220
cd0              0.0             0.0          0.0         0               0

Disks:        % tm_act     Kbps      tps    Kb_read   Kb_wrtn
------------------------------------------------------------------------------------
hdisk2          0.0             0.0        0.0          0               0
hdisk1           0.0             0.0        0.0          0               0
hdisk0          0.0             0.0        0.0          0               0
cd0              0.0              0.0        0.0          0               0

Uptime

Command:  uptime|cut -d ',' -f1,2|tr -s ' ' '^'|cut -d '^' -f 2-

11:37AM^up^159^days,^23:13

Sample Output:

Uptime =  11:16AM   up 159 days,  22:52,  3 users,  load average: 0.11, 0.06, 0.09
jobsPerMin=11%
jobsPer5Min=06%
jobsPer15Min=09%





                  New to ADManager Plus?

                    New to ADSelfService Plus?

                      • Related Articles

                      • How to troubleshoot when having error 'No data available' for LPAR CPU Stats in AIX?

                        The following should be checked if you find that data isn't populating in Applications Manager: 1)  TELNET or SSH mode connections to remote AIX servers are permitted. 2) Verify that the command below executes and produces the desired results on your ...
                      • Calculation of various attributes in Linux server

                        Physical memory utilization Command: free -m Sample Output: total used free shared buff/cache available Mem: 16338247680 6590242816 1372995584 662192128 8375009280 8734982144 Swap: 100 10 0 Calculation: Physical memory % = 100 -(((MemFree + Buffers + ...
                      • Calculation of various attributes in MACOS server

                        Memory Utilization Command: export UNIX95;top -l 1 -n 2 Sample Output: Processes: 154 total, 2 running, 152 sleeping, 600 threads  2020/03/04 14:49:04 Load Avg: 1.46, 1.60, 1.62  CPU usage: 5.40% user, 8.10% sys, 86.48% idle  SharedLibs: 202M ...
                      • Calculation of various attributes in FreeBSD server

                        Memory Utilization Command: export UNIX95;top -d 1 -n 2 Sample Output: last pid: 69468;  load averages:  0.23,  0.13,  0.09  up 439+07:00:37    18:32:00 27 processes:  2 running, 25 sleeping Mem: 8204K Active, 125M Inact, 100M Wired, 21M Buf, 109M ...
                      • Calculation of various attributes in Sun Solaris server

                        CPU Utilization CPU utilization = command=/usr/bin/vmstat 1 3  kthr      memory            page            disk          faults      cpu  r b w   swap  free  re  mf pi po fr de sr cd s0 -- --   in   sy   cs us sy id  0 0 0 1459384 744528 34 233 0  0  ...