Unable to merge or delete requests/ Unable to take a backup in new instance

Unable to merge or delete requests/ Unable to take a backup in new instance

Issue:


Cannot merge or delete requests. Also, cannot take backup in a new instance with data.

Cause:

Any of these issues may occur due to orphan entries present in DB. i.e. when we delete a service category in CMDB, it actually gets removed from UI but few related entries remain in DB.


Error trace for merge issue:

com.adventnet.servicedesk.workorder.action.WorkOrderAction]|[SEVERE]|[110]:  Exception while trying to merging as threaded request 19200|  com.adventnet.persistence.DataAccessException: SQLException occured while retrieving rows that are to be deleted from the table ServiceReq_Email Caused by: java.sql.SQLException: ERROR: column servicereq_email.udf_char8 does not exist


Fix: 
  
1. Download and extract the 1.fjar file from the below link and  place it under  \ManageEngine\ServiceDeskPlus-MSP\Fixes . 


Note: If there is no Fixes folder, please create one.

2. Restart the MSP application service. 

3. Invoke the below URL. 
   


4. It will show success or failure message depending on whether the fix is applied or not  

5. If it shows success, restart the server again and then check the issue. 


NOTE:

1.  This issue (Issue ID: 12676) is fixed permanently in the next build 9414 which is due for release by the end of Feb 2019. So, customers can upgrade to 9414 to get rid of this issue.

2. This fix is applicable to builds above 9400. Hence customer who would wish to apply the fix on the same build they are, can make use of it.




                  New to ADSelfService Plus?

                    • Related Articles

                    • Merge Similar Requests

                      Requirement: In an organization, multiple requests being created for the same issue. So we will have to merge all the similar requests. UseCase: Assume there is a printer issue in an organization, and a request has already been registered for the ...
                    • Delete requests

                      If you would like to delete the older requests, you could use the below query. Connect to the Database For MSSQL: delete from workorder where dateadd(s,datediff(s,GETUTCDATE() ,getdate()) + (CREATEDTIME/1000),'1970-01-01 00:00:00') <= ...
                    • Requests duplicated - Not deleted from inbox after fetching

                      Issue When emails are fetched as requests, the application places a delete flag which is delete the email from the inbox. In this case, the emails are not deleted allowing the application to fetch the same email again and again  Cause  Issue occurs ...
                    • How to take a backup in SDP-MSP

                      Note: In 10.6 when running a backup using backdata.bat/backdata.sh the backup file will be in .ezip format. Backup with .ezip format can be restored to the same database platform only. For example a backup with .ezip when taken from postgres DB ...
                    • Merge Similar Requests

                      Requirement: In an organization, multiple requests being created for the same issue.  So we will have to merge all the similar requests. UseCase: Assume there is a printer issue in an organization, and a request has already been registered for the ...