Unable to merge or delete requests/ Unable to take a backup in new instance

Unable to merge or delete requests/ Unable to take a backup in new instance

Issue:


Cannot merge or delete requests. Also, cannot take backup in a new instance with data.

Cause:

Any of these issues may occur due to orphan entries present in DB. i.e. when we delete a service category in CMDB, it actually gets removed from UI but few related entries remain in DB.


Error trace for merge issue:

com.adventnet.servicedesk.workorder.action.WorkOrderAction]|[SEVERE]|[110]:  Exception while trying to merging as threaded request 19200|  com.adventnet.persistence.DataAccessException: SQLException occured while retrieving rows that are to be deleted from the table ServiceReq_Email Caused by: java.sql.SQLException: ERROR: column servicereq_email.udf_char8 does not exist


Fix: 
  
1. Download and extract the 1.fjar file from the below link and  place it under  \ManageEngine\ServiceDeskPlus-MSP\Fixes . 


Note: If there is no Fixes folder, please create one.

2. Restart the MSP application service. 

3. Invoke the below URL. 
   


4. It will show success or failure message depending on whether the fix is applied or not  

5. If it shows success, restart the server again and then check the issue. 


NOTE:

1.  This issue (Issue ID: 12676) is fixed permanently in the next build 9414 which is due for release by the end of Feb 2019. So, customers can upgrade to 9414 to get rid of this issue.

2. This fix is applicable to builds above 9400. Hence customer who would wish to apply the fix on the same build they are, can make use of it.




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