AD Login Issue After Version 6150 Upgrade

AD Login Issue After Version 6150 Upgrade

Alert
Issue
AD users cannot log in to the application after upgrading to version 6150.



Warning
Cause 
 In version 6140, we introduced enhancements to the IAM module, including new login policies. As a result of these updates, a code-level issue has been identified that impacts the login functionality for Active Directory (AD) users.

We have been able to reproduce the issue locally, and it is confirmed to be present in both version 6140 and version 6150.


IdeaSolution:
    
1. Download the jar file attached here

2. Create a new folder inside the <AnalyticPlus home> directory and name the folder "fixes" (If not already available).

3. Move the downloaded patch file to the <AnalyticsPlus Home>/fixes folder.

4. Delete the entries in the below path,

F:\ManageEngine\AnalyticsPlus\conf\AD\keys

5. Restart the AnalyticsPlus services and try login again.

6. Please remove the jar once the issue is resolved.

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