AdSelfService Plus troubleshooting | Login screen freezes on loading when NTLM SSO is enabled

Troubleshooting the loading freeze error in the ADSelfService Plus login screen when NTLM SSO is enabled

Error

When NTLM authentication is enabled, ADSelfService Plus suddenly stops authenticating users and the following error is seen in the serverout file.

 

 server.security.NtlmAuthenticator: NTLM authentication error jespa.security.SecurityProviderException: NETLOGON failure 


Cause
This error is caused due to the jespa computer user account used, which may have either been deleted or disabled in the Active Directory.

 

jcifs.smb.SmbException: The SAM database on the Windows NT Server does not have a computer account for this workstation trust relationship. 

Solution  

To resolve this error, please create a new computer account and restart the service. 

                    New to ADSelfService Plus?

                      • Related Articles

                      • Troubleshooting Guide for Common Errors in ADSelfService Plus End User Portal

                        Permission denied. Please contact your administrator. Cause: There are two reasons why this error could occur: End users trying to access any of the self-service features in ADSelfService Plus such as password reset or directory self-update need to ...
                      • Sequential ADSelfService Plus Windows agent login installation process

                        This article highlights the process sequence for the ADSelfService Plus Windows login agent installation via the admin portal and the prerequisites to be addressed to successfully complete each step. Additionally, we're also discussing some common ...
                      • ADSelfService Plus product startup issues

                        What do you need to know before troubleshooting You need to have administrator access to ADSelfService Plus. When you experience an error with ADSelfService Plus, check if these prerequisites are satisfied: Install ADSelfService Plus as a service ...
                      • Configuring high availability in ADSelfService Plus

                        ADSelfService Plus utilizes automatic failover to support high availability in case of system and product failures. Essentially, this means that when the ADSelfService Plus service on one machine fails, another instance of ADSelfService Plus running ...
                      • How to prevent concurrent logins for a user in ADSelfService Plus

                        Solution Concurrent logins can lead to the use of valid credentials by illegitimate personnel at the same time as the legitimate user to authenticate to the network. This could lead to multiple security issues within the organization like misuse of ...