Troubleshooting the loading freeze error in the ADSelfService Plus login screen when NTLM SSO is enabled

Troubleshooting the loading freeze error in the ADSelfService Plus login screen when NTLM SSO is enabled

Error

When NTLM authentication is enabled, ADSelfService Plus suddenly stops authenticating users and the following error is seen in the serverout file.

 

 server.security.NtlmAuthenticator: NTLM authentication error jespa.security.SecurityProviderException: NETLOGON failure 


Cause
This error is caused due to the jespa computer user account used, which may have either been deleted or disabled in the Active Directory.

 

jcifs.smb.SmbException: The SAM database on the Windows NT Server does not have a computer account for this workstation trust relationship. 

Solution  

To resolve this error, please create a new computer account and restart the service. 

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