Upgrade issues

Upgrade issues

I was advised by support that to fix a problem I needed to upgrade from build 12417 to 12158, and in my feeling that was the worst thing I ever did. As now I have 4 of my disturbed servers that are not online and in the Data Collection Status i see a nice big red circle with an X in it and stating that Unable to contact remote machine and when i look the service is down, When I start the service I then get the error Build number mismatch between admin and this disturbed server.

I have an open case with support but it seems that they are not moving quickly ion this and hence I am posting here to see if anyone else has had this issue and how it was resolved.

As I am new to ELA this is not what i expected when i left QRadar and installed ELA.

Please help

Thank you