ServiceDesk version 11301 is incompatible with DesktopCentral version 10.0.707

ServiceDesk version 11301 is incompatible with DesktopCentral version 10.0.707

I have installed the latest version of ServiceDesk and lost connection to DesktopCentral.
I updated the DesktopCentral to version 10.0.707 provided in this link:

I have exactly the same error as this link, but none of the provided PPMs can be installed because I get a message that starts with ... "You are too early ...":

Can you provide me with the correct PPMs for the version I have?
And I also don't know why there are 2 different patch pages for DesktopCentral. What if I want to upgrade to the version for more than 750?