Server saying it needs to be updated but is already latest

Server saying it needs to be updated but is already latest

Hi,

We have upgraded to 10.1.2137.9 to fix the vulnerability but the server is still saying it needs to be updated.

We have cleared cache and even tried different browsers.


Nathan