SD Plus v14620

SD Plus v14620

I saw 14620 is available but can't install this one. On attempting to install this on test instance on v14500 I received the below on linux installation using postgresql. This was not a problem with patch v14610. The certificate already exists. I tried downloading the new cert with provided and same issue.

In the absence of a Valid certificate for the Patch Installation, it can be

downloaded from

https://www.manageengine.com/certificate/ppmsigner_publickey.crt.


Enter the certificate file to import : ppmsigner_publickey.crt

The selected certificate already exists in keystore.


The integrity of the patch is being checked. Please do not shutdown or kill the process as it needs some time.

........  Signature does not match with any available certificates. Please import valid certificate or contact support.


                New to ADManager Plus?

                  New to ADSelfService Plus?