MIB Index/Display Name Not Pulling Correctly

MIB Index/Display Name Not Pulling Correctly

I've uploaded some MIBs for the Cisco Viptela SDWAN devices, which we have running.  I've looked at the MIBs in the MIB Browser and queried the devices, and they seem to be querying correctly.  However, when I go to add a monitor for some of the OIDs I want to monitor, I'm not getting the right display name information, and so the data doesn't make a ton of sense.  

In the picture below, you can see in the MIB browser that the OID I'm looking to grab has a color for each instance that's polled, which corresponds to a particular integer - in the syntax field, it automatically converts the integer to a readable label (bronze, silver, etc.).

When I try to add the monitor, only the integer comes through.  Additionally, I've tried adding the Series Index and the Series Display Name, and I get an error.  I've tried multiple variations and they all seem to fail.  I'm not sure what I'm doing wrong and hoping someone can assist.  I'm uploading the MIB too.

                New to ADManager Plus?

                  New to ADSelfService Plus?