Issue 2 of 2: Machines aren't listed as ready

Issue 2 of 2: Machines aren't listed as ready

Here is my second issue as stated from my previous post ...

Ever since 5.0.3136 went live I've noticed the following problem: whenever I unbox and boot up new machines via PXE they aren't automatically listed under "Machines on [name of OS deployer server]"

[As an aside, I noticed this happening to even recently imaged machines, too. They will restart (because I tell them to restart in the deployment template) and invariably boot to PXE and default to the agent. Even if the newly imaged machine is ready to take another image, the management console lists the machine as "Not Ready."]

A little investigation has shown that the "ManageEngine File Server Service" has stopped in all of these cases. When I go to the event viewer on our server it shows an application error every time:

Faulting module name: fileserver.exe, version: 5.0.0.3136, time stamp: 0x585a3ded
Exception code: 0xc0000005
Fault offset: 0x00048fe6
Faulting process id: 0x5e0
Faulting application start time: 0x01d2f65d34696a8d
Faulting application path: C:\Program Files (x86)\Common Files\ManageEngine\FileServer\fileserver.exe
Faulting module path: C:\Program Files (x86)\Common Files\ManageEngine\FileServer\fileserver.exe
Report Id: 0d21f8ad-6274-11e7-80de-90e2ba0ab45f
Faulting package full name: 
Faulting package-relative application ID: 

So what fixes have I tried ...
1. Running Windows updates on our server
2. Reinstalling OS Deployer on the server
3. Removing and re-adding services on the PXE server (that shouldn't really have fixed it.)
4. Restarting the services. This rarely fixes our problem but when it does it allows us to deploy images.
5. Restarting our deployment server, sometimes once, other times two or more times, to get the machine to detect that we have a bank of computers ready to receive an image via the agent. 

There has been no consistency with intermediate fixes (really workarounds) 4 and 5, so I need your help. 

Does anybody have ideas / solutions? To the best of my recollection wasn't the case prior to 5.0.0.3136.