Google fixes several high severity vulnerabilities in Chrome 92.0.4515.131 stable channel update

Google fixes several high severity vulnerabilities in Chrome 92.0.4515.131 stable channel update

Hello everyone,

 

Chrome stable channel has been updated to 92.0.4515.131 for Windows, macOS, and Linux. This update comes with fixes for 10 security vulnerabilities. The details of the vulnerabilities fixed are as follows:

 CVE ID Vulnerability Severity
 CVE-2021-30590 Heap buffer overflow in Bookmarks High
 CVE-2021-30591 Use after free in File System API High
 CVE-2021-30592 Out of bounds write in Tab Groups High
 CVE-2021-30593 Out of bounds read in Tab Strip High
 CVE-2021-30594 Use after free in Page Info UI High
 CVE-2021-30596 Incorrect security UI in Navigation Medium
 CVE-2021-30597 Use after free in Browser UI Medium

To install this update on your Windows machines, initiate a sync between the Central Patch Repository and the Vulnerability Manager Plus server. Once the sync is complete, search for the following Patch IDs or Bulletin ID and deploy them to your target systems.

 Patch ID Bulletin ID Patch Description
 320818 TU-017 Google Chrome (92.0.4515.131)
 320819 TU-017 Google Chrome (x64) (92.0.4515.131)


Cheers,
The ManageEngine Team