Can't get HA to activate

Can't get HA to activate

Followed the documentation and everytime I enter the info for HA it tells me the credentials are incorrect, however I've used the same account on both sides and the password works. I even made a new service account and tried it but then it says the same thing. I then put the domain admin account on both sides and tried connected HA with it, same issue. The logs just show this.. I don't have Captcha enabled so I don't get it.

[12:13:41:484]|[02-14-2023]|[ADSLogger]|[INFO]|[91]: Exception while updating login status without captcha : java.lang.NullPointerException|
[12:13:41:484]|[02-14-2023]|[ADSLogger]|[SEVERE]|[91]: Exception in HAClusterServlet.authenticate() -> {"SEVERITY":"ads.admin.integration_settings.severity.severe","STATUS_MESSAGE":"ads.login.common.error.invalid_login","ERROR_CODE":"00003000"}|
[12:13:41:489]|[02-14-2023]|[ADSLogger]|[INFO]|[81]: HAErrorHandler.getStatusMsg() - > ads_admin_product_settings_ha_both_invalid_credential|
[12:13:41:489]|[02-14-2023]|[ADSLogger]|[INFO]|[81]: HAErrorHandler.getStatusMsg() - > ads_admin_product_settings_ha_settings_not_configured|

      New to ADSelfService Plus?